Backlog for Android Supported Device

Backlog for Android is compatible with Android 4.0.3 and above.